[gPXE] remote booting on HP hardware results in blinking cursor

Andrew Dwyer andrew.dwyer at dsto.defence.gov.au
Thu Nov 25 01:59:00 EST 2010


Andrew Bobulsky <rulerof <at> gmail.com> writes:

> 
> Hello Andrew,
> 
> Based on information I read at HP and then here
> http://www.broadcom.com/collateral/pg/5764M-PG100-R.pdf , it looks like your
> Z400 has a LOM NIC with
> PCI VENdor and DEVice ID's of 14E4 and 1684.  
> 
> I'm not sure if there are any Broadcom drivers currently in gPXE, but if there
> are, does anyone know which
> one[s] if any might be worth trying?

I'm not using the onboard NIC because the 1.0.1 version of gPXE that I 
downloaded from ROM-o-Matic didn’t recognise it. The network card I’m 
using is a 3Com 3C905C-TXM PCI card. 

> If you're using keep-san against an unformatted iSCSI target and booting a
> Windows 7 install disk, unless
> the NIC driver isn't present or some other software issue is preventing iSCSI
> connections, the target
> should show up as a disk in the system.  Not being able to install to it can
> happen, but that's a different
> issue with different causes, naturally 

The Windows 7 installer doesn't even show the disk as a target to 
install to, although my iSCSI server shows that the initiator is 
connected. 

> After gPXE attaches and then boots the SAN disk, if you're getting a blinking
> cursor, that could point to any
> myriad of errors (for what it's worth, I've noticed that the Windows Boot
> Manager MBR prints "SRLBCG" and
> then blanks the screen).  It could be helpful to troubleshoot by using a
> diagnostic MBR or something, but
> that's a little beyond the scope of this email.

No I don't think I've seen "SRLBCG" printed.

> I usually troubleshoot errors that you're experiencing by trying a different
> NIC.  Sometimes the UNDI
> driver, if that's what you're using, doesn't play nice with all NICs.
> 
> A few questions though for myself or others to help you troubleshoot:
> 
> What iSCSI target are you using?

I’m using tgt installed on CentOS though I’ve also tried iscsitarget on ubuntu.

> What method are you using to boot gPXE?

dhcp net0
sanboot iscsi:host:::1:iqn.2010-11.foo:bar 

This results in a blinking cursor as described in my original email. 
I’ve tried using lun 0 using iscsitarget but that doesn’t make a 
difference. For some reason tgt doesn’t let me use lun 0. 

When installing Windows 7 I use these commands (note: I followed Matt’s 
advice and added the initiator name line): 

dhcp net0 
set keep-san 1
set initiator-iqn INITIATORNAME
sanboot iscsi:host:::1:iqn.2010-11.foo:bar 

As described before, the Windows 7 installer doesn’t display the disk. 

> Have you tried any other NICs?

Just the onboard NIC and a PCI card. I can try a different one if you 
think that would help? Would any of the other hardware cause an issue? 
Or is it just the NIC that matters? 

Thanks for your help! 

Andrew Dwyer 




More information about the gPXE mailing list